cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leszek Gawron" <o...@wlkp.org>
Subject RE: FormValidatorAction & regexp matching
Date Fri, 30 Jan 2004 12:48:24 GMT
> What does 'older version' mean? Jakarta RegExp was updated from 1.2 to 1.3
> on
> 4th of September (between release of 2.1 and 2.1.1). The actions
> (FormValidatorAction and more important
> AbstractValidatorAction) don't have much changed in the last months:
> http://cvs.apache.org/viewcvs.cgi/cocoon-2.1/src/java/
> org/apache/cocoon/acting/AbstractValidatorAction.java

After a little research I found out that it works with Tomcat because Tomcat
4.1.27 contains server\lib\jakarta-regexp-1.2.jar. Overwritting 1.3 version in
cocoon with 1.2 and running in Jetty got it working.

Another question is: if I want to be sure that all classes that cocoon uses
are fetched from cocoon/web-inf/lib should I use ParanoidCocoonServlet?

-- 
	Leszek Gawron




Mime
View raw message