cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MJ Stahl <mjst...@mac.com>
Subject Re: Errors with Cocoon 2.1.3/2.2-dev buil (OS X 10.3)
Date Sat, 10 Jan 2004 19:00:29 GMT
I think I may have found the problem. Please correct me if I am wrong.


> Below is a traceback of a failed build on Mac OS X 10.3. These 2  
> errors are found in both the Cocoon 2.1.3 distribution as well as the  
> 2.2-dev (retrieved from CVS).
>
> /Users/mjs/Desktop/cocoon-2.2/src/java/org/apache/cocoon/components/ 
> flow/javascript/JavaScriptInterpreter.java:164: cannot resolve symbol
> symbol  : method setOptimizationLevel (int)
> location: class org.mozilla.javascript.tools.debugger.Main
>             db.setOptimizationLevel(OPTIMIZATION_LEVEL);
>               ^

db is an instance of org.mozilla.javascript.tools.debugger.Main, which  
inherits ContextListener.

setOptimizationLevel() is defined within org.mozilla.javascript.Context.

ContextListener doesn't inherit Context, which is the file that is  
imported in JavaScriptInterpreter.java.

I recommend either changing
	import org.mozilla.javascript.Context 	=>  import  
org.mozilla.javascript.ContextListener

Or the safer bet would be to just add another import statement for  
ContextListener.


I believe this solution will fix both files  
(JavaScriptInterpreter.java, and FOM_JavaScriptInterpreter.java)

------------------------------------------------------------------------ 
--------
M. J. Stahl

"I must create a system, or be enslaved by another man's."
	-- William Blake


Mime
View raw message