cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Portier <...@outerthought.org>
Subject Re: Rename "union" to "select"?
Date Mon, 05 Jan 2004 15:46:00 GMT


Tim Larson wrote:

<snip/>

>> From that perspective I would recommend as a general line of thinking 
>>to choose names reflecting concepts from XSD, relaxNG, UML while making 
>>sure they would not be confusing to people aware of HTML,css,js?
> 
> 
> Then it is a good thing I asked on the list.  My background is from
> other programming languages, not XML, HTML, UML, etc.
> 
> 

oh yeah, asking others, and then waiting some time to let it sink in :-)

during our private discussion I was still somewhat leaning to 'select' 
it was only after looking out for some argumentation on Anthonio's 
statement that I came to consider xmlschema's

>>Hm, so taking up that rule, maybe we should avoid the confusion with 
>>HTML's <select><option> and should maybe rather let <wd:union> become
a 
>><wd:choice>
> 
> 
> +1
> 

glad you like it :-)

-marc=
-- 
Marc Portier                            http://outerthought.org/
Outerthought - Open Source, Java & XML Competence Support Center
Read my weblog at                http://blogs.cocoondev.org/mpo/
mpo@outerthought.org                              mpo@apache.org


Mime
View raw message