cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: cvs commit: cocoon-2.1/src/java/org/apache/cocoon/components/source/impl SitemapSource.java
Date Thu, 11 Dec 2003 09:07:59 GMT
Giacomo Pati wrote:
>
> Carsten Ziegeler wrote:
> > Vadim Gritsenko wrote:
> >
> >>  -        this.reset();
> >>  -        this.init();
> >>  +        reset();
> >>  +        init();
> >
> >
> > Why do you make these changes? A long time ago, we decided  that
> > this.method()
> > is more readable and we want to use that :)
>
> More readable? There is no semantic difference between this.method() and
> method(). Actually I find it silly to add the 'this.' to a method call.
>
If you write method(), you don't know if you call a static method or not.
If you write this.method(), at least the compiler gives you a warning
*if* you call a static method. So if you use it wisely, you see what's
going on.

> It make sense for member variables but there I'd like to add a prefix
> like m_ which cannot be forgotten (as like the 'this.' prefix) and thus
> clearly indicates what kind of variable it is (but that is personal
> preference, I know ;-)
>
:) Please, everything, but not adding these prefixes like 'm_'.

So, in the end, we see here why we shouldn't have strikt coding conventions,
the opinions differ widely :)

Carsten


Mime
View raw message