cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@informatik.tu-darmstadt.de>
Subject Re: cvs commit: cocoon-2.1/src/java/org/apache/cocoon/components/source/impl SitemapSource.java
Date Thu, 11 Dec 2003 08:42:17 GMT
Giacomo Pati wrote:
> 
> Carsten Ziegeler wrote:
> 
>> Vadim Gritsenko wrote:
>>
>>>  -        this.reset();
>>>  -        this.init();
>>>  +        reset();
>>>  +        init();
>>

> It make sense for member variables but there I'd like to add a prefix 
> like m_ which cannot be forgotten (as like the 'this.' prefix) and thus 
> clearly indicates what kind of variable it is (but that is personal 
> preference, I know ;-)

>> No, actually I prefer this.method() as well, but don't mind if someone
>> writes
>> only method(). But I think changing this back and forth is not a good 
>> idea.

Personally, I prefer the this.reset() approach to m_reset(). But at the
end of the day I second Carsten to not regulate this but please don't
change back and forth.

	Chris.

Mime
View raw message