cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: cvs commit: cocoon-2.1/src/java/org/apache/cocoon/components/source/impl SitemapSource.java
Date Thu, 11 Dec 2003 02:59:19 GMT
On 10.12.2003 22:56, Vadim Gritsenko wrote:

>>>> Why do you make these changes? A long time ago, we decided  that
>>>> this.method()
>>>> is more readable and we want to use that :)
>>>
>>> Is it? Sorry I might have missed that. It just looks so silly (there 
>>> is no notion of local methods - so you can't mistake it for local 
>>> method) ;-)
>>
>> You can differ static from non-static methods.
> 
> No, you can't. Example: this.ROLE will compile just fine.

Eh? I don't understand. Of course there is no compiler error, but where 
is the problem using this.method() for instance methods and method() for 
class methods. Isn't this exactly the same as for fields (though there 
are additionally the local variables)? Furthermore using this.method() 
for class methods gives a compiler warning "should not be accessed in a 
static way" or similar.

> BTW, you can see this in my today's commit, log: static access.

Yes, saw it - and I had to search a long time for the difference ;-)

Joerg


Mime
View raw message