cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Larson <>
Subject [cforms] Renaming party for union, etc.
Date Mon, 08 Dec 2003 17:02:08 GMT
For anybody who been following the class, new, struct, and union discussion,
will you help choose intuitive names for these new features?

I am thinking of changing:
  "union"->"selector", "selection", "choose", "choice", etc.
  "class"->"define" or leave as "class"
  "new"->"use", "instance", or leave as "new"

Note that the concept currently called "class" may be reused in a global
widget definition repository, and that the concept currently called "new"
may be extended to allow it to provide customization parameters or elements
to the definitions it creates instances of.

What names do you all suggest?  The names will be used for the parallel
concepts in the form definition, template, and binding.  It would be nice
to get the names settled for the next patch before this gets committed.

--Tim Larson

Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.

View raw message