cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Dumon <>
Subject Re: [cforms] Renaming party for union, etc.
Date Tue, 09 Dec 2003 21:30:37 GMT
On Mon, 2003-12-08 at 18:02, Timothy Larson wrote:
> For anybody who been following the class, new, struct, and union discussion,
> will you help choose intuitive names for these new features?
> Description:
> Patch:
> I am thinking of changing:
>   "union"->"selector", "selection", "choose", "choice", etc.
>   "struct"->"container"
>   "class"->"define" or leave as "class"
>   "new"->"use", "instance", or leave as "new"
> Note that the concept currently called "class" may be reused in a global
> widget definition repository, and that the concept currently called "new"
> may be extended to allow it to provide customization parameters or elements
> to the definitions it creates instances of.
> What names do you all suggest?  The names will be used for the parallel
> concepts in the form definition, template, and binding.  It would be nice
> to get the names settled for the next patch before this gets committed.

I would keep the current names (union, struct, class, new).

Bruno Dumon                   
Outerthought - Open Source, Java & XML Competence Support Center                

View raw message