cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tuomo L <tleso...@cc.hut.fi>
Subject RE: Logging problems
Date Tue, 04 Nov 2003 16:11:44 GMT
I have declared my own category in logkit.xconf, and have a target for it
too. In sitemap I have logger="mycategory" and nothing gets logged. The
target is created in WEB-INF/logs correctly during startup. No logging
happens though. This worked ok with Cocoon 2.1. Not anymore.

In sub-sitemap.xmap:

<map:action name="myaction" logger="mycategory" src="foo.bar.MyAction"/>

In logkit.xconf:

<targets>

<cocoon id="mycomponent">
      <filename>${context-root}/WEB-INF/logs/mycomponent.log</filename>
      <format type="cocoon">
        %7.7{priority} %{time}   [%{category}] (%{uri})
%{thread}/%{class:short}: %{message}\n%{throwable}
      </format>
      <append>false</append>
    </cocoon>

</targets>

<categories>
  <category log-level="DEBUG" name="mycategory">
      <log-target id-ref="mycomponent"/>
      <log-target id-ref="error"/>
  </category>
</categories>


Whats happening?

-Tuomo

On Tue, 4 Nov 2003, Unico Hommes wrote:

>
> Either change the logger category of your declared component from
> sitemap.my.category to my.category or expect the actual category to be
> sitemap.sitemap.my.category.
>
> -- Unico
>
> >
> > -----Original Message-----
> > From: Tuomo L [mailto:tlesonen@cc.hut.fi]
> > Sent: dinsdag 4 november 2003 16:02
> > To: dev@cocoon.apache.org
> >
> > Hi,
> >
> > Has there been some changes to the logging system since
> > Cocoon 2.1? I updated to 2.1.2 (by copying the new jars to my
> > project-dir) and the logging of my custom sitemap components
> > stopped working. Any ideas on this?
> >
> > -Tuomo
> >
> >
>

Mime
View raw message