cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Unico Hommes" <Un...@hippo.nl>
Subject RE: Introducing IOC for Java classes created in flowscript
Date Sun, 30 Nov 2003 20:02:34 GMT


Sylvain Wallez wrote:
> 
> Carsten Ziegeler wrote:
> 
> >BTW, wasn't there a discussion about renaming getComponent() to 
> >lookup()?
> >  
> >
> 
> Not that I know, but I like it as it's more consistent with 
> "plain old 
> Java" code. Now I think we should keep the "-Component" 
> suffix since the 
> cocoon object is more than a ServiceManager.
> 
> So what about "lookupComponent()" ?

+1

Component is fine. lookup is better than get. But can we keep support
for getComponent in the 2.1 branch? I think a lot of users already rely
on it.

Unico

Mime
View raw message