cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: [WIKI-UPDATE] FirstFridayDecember2003 Thu Nov 27 09:00:02 2003
Date Thu, 27 Nov 2003 16:31:20 GMT
Joerg Heinicke wrote:

I played a bit with it - and didn't got it working ...

>> (1) drop xindice CVS version into blocks/xmldb/lib;
> 
> And I guess lib/optional is better

I meant lib/local. I placed the xindice.jar there, rebuilt Cocoon and the 
JAR is now in WEB-INF/lib.

>> (2) add xindice-embed driver as <driver 
>> class="org.apache.xindice.client.xmldb.embed.DatabaseImpl" 
>> type="xindice-embed"/> to the cocoon.xconf;

This is done automatically when including the xmldb block with a little 
difference:

<driver class="org.apache.xindice.client.xmldb.DatabaseImpl" 
type="xindice-embed"/>

I have fix this locally. My cocoon.xconf after building Cocoon has the 
following entry:

     <!-- xmldb pseudo protocol -->
     <component-instance 
class="org.apache.cocoon.components.source.impl.XMLDBSourceFactory" 
name="xmldb">
         <!-- Xindice driver -->
         <driver class="org.apache.xindice.client.xmldb.DatabaseImpl" 
type="xindice"/>
         <!-- Xindice 1.1 Embedded driver -->
         <driver class="org.apache.xindice.client.xmldb.embed.DatabaseImpl" 
type="xindice-embed"/>
         <!-- Add here other XML:DB compliant databases drivers -->
     </component-instance>


>> (3) move xmldb demo pipeline up, before automount;
> 
> Why isn't this done by default? I can change it if nothing objects.

Why there is no samples directory in the xmldb block as it is done for all 
the other blocks? Adding it to samples pipeline is not that fine I think. 
Fixed it locally ...

>> (4) restart and go to http://localhost:8888/samples/xmldb/
> 
> Have you tried it recently? Especially as one mentioned that it works with
> 2.1.2 and no longer with current 2.1.4-dev [1]. Has something changed that
> we should document anywhere?

As I wrote it does not work for me. I got following exception:

org.apache.excalibur.source.SourceNotFoundException: 
xmldb:/home/jheinicke/cocoon-2.1/xindice:/localhost:4080/db doesn't exist.

Caused by: java.io.FileNotFoundException: xindice:/localhost:4080/db (No 
such file or directory)


When using the deprecated generators I got following exception:

Unable to fetch content: A connection to the Database instance 'db' could 
not be created. Error: Connection refused
	at 
org.apache.cocoon.generation.XMLDBGenerator.generate(XMLDBGenerator.java:212)

How to go on? Anything I forgot?

Joerg

-- 
System Development
VIRBUS AG
Fon  +49(0)341-979-7419
Fax  +49(0)341-979-7409
joerg.heinicke@virbus.de
www.virbus.de


Mime
View raw message