cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <jheini...@virbus.de>
Subject Re: ESQL Connection Pool hangs
Date Mon, 17 Nov 2003 15:09:11 GMT
(Question to dev, CC users)

Shall we update excalibur-database to 1.1.2-dev-mavenized?

Joerg

On 17.11.2003 11:47, Mirco Goergen wrote:
> Hi
> 
> Thanks for your replay. 
> 
> I upgrade to Version 2.1.3 but the Version number from excalibur-datasource is still
1.1.1 
> 
> Unfortunatly the problem does occur only from time to time, is it possible to force this
error to be sure that I m on the right side or would it even be better to exchange the jar
from latest developer version?
> 
> regards
> 
> Mirko
> 
> 
>>>>frank.taffelt@interface-business.de 11/17 10:43  >>>
> 
> the excalibur-datasource-1.1.1.jar contains a bug that can be the source for
> your problems. The database pooling is going out of sync and after some time
> the pool is empty and therefore hangs until restart.
> 
> Solution:
> Update your excalibur datasource jar to a version after 18.07.2003.
> 
> hth
> Frank
> 
> ----- Original Message -----
> From: "Mirco Goergen" <mgoergen@compu-shack.com>
> To: <users@cocoon.apache.org>
> Sent: Sunday, November 16, 2003 1:53 PM
> Subject: ESQL Connection Pool hangs
> 
> 
> 
>>Hello
>>
>>If have set two connection pool within cocoon.xconf
>>
>>One for Mysql the other for Oracle. Both working fine and I could handle
> 
> my sql via xsp and action perfectly.
> 
>>Unfortunatly after some hours of running the Mysql Connection hangs and I
> 
> got no error whats going on with this connection. It seems to me that Cocoon
> is still trying to connect, but got no respone from mysql db. Pages from
> Cocoon without using Mysql are still working. Also Connection to Oracle is
> still alive.
> 
>>If I try to connect to the same mysql db in a different way, it still
> 
> works. Restarting Tomcat solve the problem until it hangs again.
> 
>>I using Cocoon 2.1 Mysql 4.0.16 Latest Mysql JDBC driver and
> 
> j2sdk1.4.1_01. All this parts are on one machine (it s a big one :-) so
> firewall could not cause my trouble.
> 
>>I also tried to connect to Mysql using the autoReconnect still the same
> 
> result.
> 
>>Any help to this problem are welcome.
>>
>>thanks a lot
>>
>>Mirko Görgen
>>
>>Mit freundlichem Gruß
>>
>>Mirko Görgen
>>Webadministrator
>>
>>Firma: Compu-Shack
>>Tel: 0 26 31 - 98 31 48
>>Fax: 0 26 31 - 98 31 99
>>www.compu-shack.com


Mime
View raw message