cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Bouterse <martijnboute...@freeler.nl>
Subject Re: [GT2003] cannot play 20-town-hall.avi video
Date Tue, 11 Nov 2003 13:52:36 GMT
Bertrand Delacretaz wrote:

> I downloaded this video from two different mirror locations but neither 
> does work here (macosx 10.2.8, tried with QuickTime and Windows Media 
> Player), QuickTime says "program error" and WMP says "wrong format".
> 
> Does it work for others? The MD5 of the file that I have is
> 
> b6d698b4d4f98c38d5e382a9e3f82d61  20-town-hall.avi

GSpot[1] says about this file:

"
This is an invalid AVI file due to corruption of the data in the header. 
  This is a serious problem, and this file is not likely to playable

Details: While processing chunk /RIFF:AVI , found bad length value 8822 
at file offset 0x00000010
"

Then I tried to open it with VirtualDub[2]. VirtualDub reported that the 
index block was missing and reconstructed it using a file scan. I 
re-saved the file and GSpot reported the following:

"
  DirectShow claims to be able to play the file. The following 
combination of filters were used:

  {C:\temp\cocoon\20-town-hall_resave.avi} (Source)
  {AVI Splitter} (Splitter)

  {DivX Decoder Filter} (Video Decoder)
  {Video Renderer} (Video Renderer)

  {MPEG Layer-3 Decoder} (Audio Decoder)
  {Default WaveOut Device} (Audio Renderer)
"

So that's the trick and the new file played happily :-).

HTH, HAND

Martijn Bouterse

[1] http://www.headbands.com/gspot/
[2] http://www.virtualdub.org/index



Mime
View raw message