cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Reinhard Poetz" <reinh...@apache.org>
Subject RE: Thoughts on flowscripts....
Date Fri, 14 Nov 2003 17:04:27 GMT


> -----Original Message-----
> From: Andrzej Jan Taramina [mailto:andrzej@chaeron.com] 
> Sent: Friday, November 14, 2003 5:52 PM
> To: dev@cocoon.apache.org
> Subject: Thoughts on flowscripts....
> 
> 
> Been thinking about the flowscript issue, and wanted to float 
> some other 
> thoughts regarding consistency.
> 
> In my mind, some level of consistency is a "good thing(tm)", 
> and leads to two 
> precepts:
> 
> 1) Consistent syntax should perform consistently similar functions.
> 2) Consistent names should denote consistent things.
> 
> So that begs the question:
> 
> Why does <map:call resource="xxx"/> behave like a method 
> invocation and 
> returns to the sitemap and continues execution a the point 
> that was left off 
> (assuming the last item in the resource wasn't a serializer).
> 
> But <map:call function="xxx"/> is expected to never return by 
> always doing a 
> showPage() or showPageAndWait()?
> 
> This is a Cocoon inconsistency in how <map:call> behaves 
> which breaks the 
> first precept.
> 
> Maybe it should be renamed <map:flowscript fuction="xxx"> in 
> the latter 
> circumstance or something other than <map:call>?
> 
> In most programing languages in common usage a "call" implies 
> a return, so 
> there is also an inconsistency here with accepted terminology 
> with respect to 
> the flowscript syntax. This breaks the 2nd precept wrt to 
> common definitions.
> 
> Just some thoughts...

One note: With VirtualSitemapComponents map:resource will be deprecated.

--
Reinhard


Mime
View raw message