cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Quinn <jer...@media.demon.co.uk>
Subject Re: NPEs in FlowLayer
Date Wed, 29 Oct 2003 14:54:24 GMT

On Wednesday, October 29, 2003, at 12:10 PM, Ugo Cei wrote:

> Jeremy Quinn wrote:
>> Hi All
>> I am getting mysterious NPEs in the flowlayer, while working with the 
>>  flow version of  'authentication-fw'.
>> Not only are they odd, they are completely inconsistent.
>> They tend to happen after a script redirects after eg. a bad login.
>
> I've just committed a workaround for a case where I was getting NPEs. 
> Looks like, in some cases, an already invalidated instance of 
> FOM_Cocoon is being reused, but of course all its fields have already 
> been set to null.
>
> My patch is just a workaround, since this situation should never 
> happen, but I haven't been able to determine the real cause. Besides, 
> adding a couple extra null checks isn't going to hurt anyway, and 
> should the situation arise, you'll get a message on System.err (not 
> via the Logger, since it's already been nulled as well).
>
> You might also check Vadim's commit of yesterday to see if it's 
> relevant.

Thanks Ugo

I just tried the update, but am still getting very unpredictable 
behaviour.

I will login successfully, logout, then login again, the second time 
around, I get NPEs from cocoon.log.info. NPEs that I did not get the 
first time around.

Och! its doing ma heed in!

FlowScript does seem to be very broken ATM, because all this worked 
fine last week.

regards Jeremy


Mime
View raw message