cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Quinn <jer...@media.demon.co.uk>
Subject Re: NPEs in FlowLayer
Date Wed, 29 Oct 2003 17:50:32 GMT

On Wednesday, October 29, 2003, at 05:10 PM, Christopher Oliver wrote:

> Can you recreate this problem with a simple example you can post to 
> the list?

I'll do my best to ....

Thanks

regards Jeremy

> Jeremy Quinn wrote:
>
>>
>> On Wednesday, October 29, 2003, at 04:28 PM, Ugo Cei wrote:
>>
>>> Jeremy Quinn wrote:
>>>
>>>> I will login successfully, logout, then login again, the second 
>>>> time around, I get NPEs from cocoon.log.info. NPEs that I did not 
>>>> get the first time around.
>>>
>>>
>>> I suggest that you add some more null checks in FOM_Cocoon, if you 
>>> have identified the source lines that dereference nulls in your 
>>> case. Defensive programming is A Good Thing (TM).
>>
>>
>> :)
>>
>> Yeah, but something has broken to cause them ..... I only put them in 
>> because I am trying to see why my request params are sometimes 
>> (incorrectly) null ..... when Flow calls Flow Pipelines internally, 
>> something very strange starts happening ..... you begin to loose bits 
>> of the infrastructure after you come out the other side.
>>
>> nasty business!!
>>
>> Is anybody else attempting to do development of FlowScripts ATM with 
>> the current CVS and finding these problems? (Or is it just us two?).
>>
>> regards Jeremy
>>
>>
>
>


Mime
View raw message