cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Hochsteger <e9625...@student.tuwien.ac.at>
Subject Re: [BUG] Cocoon doesn't handle trailing slashes correctly
Date Sat, 01 Nov 2003 07:29:23 GMT

Stefano Mazzocchi wrote:

> 
> On Friday, Oct 31, 2003, at 19:11 Europe/Rome, bugzilla@apache.org wrote:
> 
>> ------- Additional Comments From joerg.heinicke@gmx.de  2003-10-31 
>> 18:11 -------
>> It's the second hint within two weeks that Cocoon seems not to handle 
>> trailing
>> slashes correctly:
>>
>> http://marc.theaimsgroup.com/?t=106633602700004&r=1&w=2
> 
> 
> I have experienced this problem right now. I have a sitemap matcher like 
> this
> 
>    <map:match pattern="webdav/**">
>      <map:mount check-reload="yes" src="webdav://localhost/webdav/{1}" 
> uri-prefix=""/>
>    </map:match>
> 
> that mounts on an external DAV server.
> 
> Asking for
> 
>  http://localhost:8888/samples/webdav/
> 
> gives me the following error
> 
>   Could not get WebDAV resource 
> webdav://localhost:80/webdav/webdav/sitemap.xmap
> 
> Note the double "webdav"!!!

Am I missing something, or is the empty uri-prefix the cause of the problem?
Shouldn't it be uri-prefix="webdav"?

> 
> If I ask for
> 
>  http://localhost:8888/samples/webdav/whatever
> 
> I get the error
> 
>   Could not get WebDAV resource webdav://localhost:80/webdav/whatever
> 
> as it is supposed to be.
> 
> So, why is the ending slash transformed into another copy of the last 
> path fragment?
> 
> -- 
> Stefano.
> 

Bye,
	Andreas



Mime
View raw message