cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: Flow problem on Weblogic 8.1
Date Thu, 16 Oct 2003 13:55:49 GMT
Christopher Oliver wrote:

> Welcome to classpath hell :( The problem seems to be that Weblogic 
> server's class loader exposes its own copy of Rhino so the version 
> packaged with Cocoon is not used. In my opinion, this is fundamentally 
> a bug with BEA's product. However that opinion doesn't help you much. 
> This problem is compounded by the fact that BEA also has a forked 
> version of Rhino so you can't just
> replace the Weblogic rhino jar with the one from Cocoon or you'll 
> break parts of Weblogic.


So the simple solution may be to use the ParanoidCocoonServlet !

It was made just for solving this jar hell, by loading the Cocoon 
servlet (or any other servlet) in a "shielding" classloader that will 
load everything (class and resources) from WEB-INF first and from 
upper-level classloaders next.

Sylvain

-- 
Sylvain Wallez                                  Anyware Technologies
http://www.apache.org/~sylvain           http://www.anyware-tech.com
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }
Orixo, the opensource XML business alliance  -  http://www.orixo.com



Mime
View raw message