cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agsoftware.dnsalias.com>
Subject Re: [SOLUTION] - Re: [Woody binding] - o.a.commons.jxpath.JXPathException: Exception trying to create xpath areas[7]; InsertBean jxpath factory failed.
Date Sun, 26 Oct 2003 22:33:20 GMT
Sylvain Wallez dijo:
> Antonio Gallardo wrote:
>>The JDO specification said (chapter 14.6.1 page 105):
>><snip>
>>14.6.1 Query Execution
>>
>>The Query interface provides methods that execute the query based on
>> the parameters given. They return an unmodificable Collection.....
>></snip>
>>
>>The last sentence is the root of the problem. I got this Collection and
>> tried to modify it by adding a new row to the woody repeater. This is
>> why I got the error described in the first mail of the thread.
>>
>>At this point Flow+Woody+OJBwithJDO is working fine. I will continue
>> the tests. :-D

> Interesting point to know, but I'm not sure this is _the_ reason.
> Looking at the exception, it looks more like a JXPath problem (cannot
> find a property write method or something like that). Or is there
> another chained exception that you did not post?

Nope. There was not another chained exception at all. This is simply why
it takes me 2 days to discover the error!

After posting the mail and rewriting the getList() method to "copy" the
data from the returned Query collection to a new bean then the
form.save(bean) works fine.

I also did another trick:

If I used "other" bean for form.save(newBean) it works too. But I have a
very hard head and I wanted to save back to the same bean. This is why I
debugged and tried like crazy. :-D

Well, another interesting stuff is that I discovered that JXPath first
call the method "addArea" with a empty bean and then fill the bean. It is
interesting to me :-)

Best Regards,

Antonio Gallardo





Mime
View raw message