cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <>
Subject Re: cvs commit: cocoon-2.1/src/blocks/html/lib .cvsignore jtidy-04aug2000r7-dev.jar
Date Tue, 26 Aug 2003 19:16:50 GMT
Carsten Ziegeler wrote:
> Roger I Martin PhD wrote:
>>Just a thought about something I've run into.  When a third party makes a
>>block or webapp that depends on the same lib but a different version, can
>>the jar indexing capability of jdk1.4 jar utility be employed to 
>>resolve the
>>issues?  It involves placing and maintaining a correct Class-Path: ... in
>>the jar's manifest and then running jar -i *.jar.
> Perhaps, but we have must be compatible with jdk 1.3 and we have the same
> version of a jar twice :(
> But thanks for the pointer anyway!

Actually, I'm looking into it now, but it seems to be identical in 1.4 
and 1.3 so it may actually come in useful in general in real blocks.  It 
won't help us with the current build problem of having two versions when 
we only want one.  If I understand it right though, it should help us 
sort out the thorny classloader issues that could arise when blocks 
contain competing versions of the same jars/classes.


View raw message