cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Fagerstrom <dani...@nada.kth.se>
Subject Re: Revisited Proposed Flow Renaming (was Re: [Vote] Controller/Sitemap integration)
Date Fri, 18 Jul 2003 15:52:22 GMT
  Marc Portier wrote:
...

> -2- Interpreter should be changed to FlowProcessor (more sense then 
> FlowEngine becomes apparent now?) and its methods could make the 
> transition from
>   callFunction(String funcName, List params, Environment env)
>   handleContinuation(String contId, List params, Environment env)
> towards
>   initiateFlow(String flowId, List params, Environment env)
>   continueFlow(String contId, List params, Environment env)
>
> which maybe gets mapped back to the
>
> <map:initiate flow="flowId" type="interpreter-name" />
> <map:continue flow="contId" type="interpreter-name" />
>
> that was still under discussion somewhat?

Flowscripts are not only usable for handling page flow in webapps, you 
can also write flowscripts that perform some side effects and ends with 
a sendPage, (and not use any sendPageAndWait), i.e. perform a side 
effect and return a page. This use will not set up any continuation 
object and have about the same use cases as actions. I would guess that 
people who write a lot of flowscripts will prefer this construction 
before with actions. For this use case "call" seem to be a much more 
natural name than "initiate" while they IMHO has similar descriptive 
value for multi page flow I would prefer the naming as is..

/Daniel



Mime
View raw message