cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: cvs commit: cocoon-2.1/src/scratchpad/src/org/apache/cocoon/generation TraversableGenerator.java
Date Thu, 10 Jul 2003 20:50:32 GMT
Sylvain Wallez wrote:
> Geoff Howard wrote:

...

>> Wild proposal: merge all code into one class, named something very 
>> clear (like TraversableSourceHierarchyGenerator) and subclass that 
>> with DirectoryGenerator (or something very like it) and have that 
>> subclass override nothing:
>>
>> public class DirectoryGenerator extends 
>> TraversableSourceHierarchyGenerator {
>>
>> /**
>>  * Identical to superclass - class only for name/function clarity.
>>  **/
>>
>> }
>>
>> too crazy? 
> 
> Not so crazy, but incompatible with existing project-specific extensions 
> of the class, as I already mentioned in this thread.

Yes, this and the namespace issue Joerg raised means you can't have 
strict back-compatibility with DirectoryGenerator.  So what about:
- leave DirectoryGenerator as-is and deprecate it
- Merge desired capabilities from it into TraversableSourceG
- Name the above proposed subclass to something else like 
"DirectorySourceGenerator" or "DirectoryTraversalGenerator" or
"DirectoryListingGenerator" or something as obvious.


Geoff


Mime
View raw message