cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: Tomcat 4.1.24 + Cocoon 2.1M3 : yet another endorsed lib issue...
Date Tue, 08 Jul 2003 13:53:18 GMT
Olivier Billard wrote:

> Thanks for your answer...
>
> ... but your wiki says why to use the ParanoidServlet, but not how to 
> use it ... 


Erhm... edit your web.xml and change the servlet class name from 
org.apache.cocoon.servlet.CocoonServlet to 
org.apache.cocoon.servlet.ParanoidCocoonServlet ! It's as easy as that ;-)

> Is this already in use with a cocoon older than 6th June ? 


No, because the code before this date was buggy. But you can extract 
ParanoidCocoonServlet and ParanoidClassLoader from after june 6th and 
put it in an older Cocoon (of course removing the old classes).

Sylvain

-- 
Sylvain Wallez                                  Anyware Technologies
http://www.apache.org/~sylvain           http://www.anyware-tech.com
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }
Orixo, the opensource XML business alliance  -  http://www.orixo.com



Mime
View raw message