cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hunsberger, Peter" <Peter.Hunsber...@stjude.org>
Subject RE: cvs commit: cocoon-2.1/src/scratchpad/src/org/apache/cocoon/generation TraversableGenerator.java
Date Thu, 10 Jul 2003 19:37:42 GMT
Geoff Howard <cocoon@leverageweb.com> writes:
> Wild proposal: merge all code into one class, named something 
> very clear (like TraversableSourceHierarchyGenerator) and 
> subclass that with DirectoryGenerator (or something very like 
> it) and have that subclass override nothing:
> 
> public class DirectoryGenerator extends 
> TraversableSourceHierarchyGenerator {
> 
> /**
>   * Identical to superclass - class only for name/function clarity.
>   **/
> 
> }
> 
> too crazy?

You might actually want to have some implementation specific method
names if you did this.  In particular, the setLeaf, setNode issue could
have nicer semantics for the  directory implementation with setFile,
setDirectory methods being added that did nothing but forward the calls
on as appropriate. (Polymorphism for method names :-)...


Mime
View raw message