cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Pötz <reinhard_po...@gmx.net>
Subject RE: [Vote] Controller/Sitemap integration
Date Thu, 17 Jul 2003 09:34:49 GMT

As I have been confused by all those suggestions you can find a summary
here: 
http://wiki.cocoondev.org/Wiki.jsp?page=FlowSitemapIntegration

After the discussion and all your opinions I would prefer:

Integrating the flow processor/engine:
--------------------------------------

<map:flows>
  <map:flow name="js" type="javascript">
     <script src="flow/PetStoreImpl.js"/>
     <script src="flow/petstore.js"/>
  </map:flow>
  <map:flow name="java" type="atct">
    <class src="org.apache.cocoon...."/>
  </map:flow>
  <map:flow name="fsm" type="fsm">
    <blabla src="descriptors/fsm.xml"/>
  </map:flow>
</map:flows>

... in order to be coherent. Please note that the flow
element only has name and type. All other things
are IMO part of the configuration (... someone proposed
to have a class attribute --> that's useless for e.g. the
JavaScript implementation)


Call a flow the first time:
---------------------------
<map:call flow="[yourFlow]" type="js">
    <map:parameter name="x" value="y"/>
</map:call>

I prefer "call" because this makes the most sense for me.
But I'm +0.5 with initialize. And I like the word flow otherwise
it is totally obscured that it is part of the flow implementation.

Please note again that we need a "type" attribute again.

... and I don't like src because src means something different
everywhere in Cocoon (something that can be called using the
SoureResolver ...)


Continue a flow:
----------------
<map:continue id="..." type="js">
   <map:parameter name="x" value="y"/>
</map:continue>

Again, I don't like src (see reasons above) and we need the type
attribute.


Component declaration:
----------------------
I'm indifferent on this ...


--------------------------------------------------------------------

And here a completly new alternatvie (at least for this discussion:)

<map:flow call="" type="js" >
   <map:parameter name="x" value="y"/> 
</map:flow>

and

<map:flow continue="" type="java" >
   <map:parameter name="x" value="y"/> 
</map:flow>

This makes for me the greatest sense because you still know that you
deal
with flow and this is not obscured by call, continue, initialize or
whatever.


Perhaps, this would make a renaming of the declaration in
<map:flows>...</map:flows>
necessary.


What do you think?

Cheers,
Reinhard


Mime
View raw message