cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Pötz <reinhard_po...@gmx.net>
Subject [Vote] Controller/Sitemap integration
Date Wed, 16 Jul 2003 16:12:27 GMT

After the "balkanization" discussion it's time to vote on this last
point before we can release Cocoon 2.1 with stable public interfaces:

Out of Sylvain's RT 
[http://archives.real-time.com/pipermail/cocoon-devel/2003-July/016291.h
tml]


> So here are the proposed refactorings :
> 
> 1/ In the flow classes. These changes will be totally transparent to 
> both existing sitemaps and existing flow scripts.
>   - rename "Interpreter" to "FlowEngine",
>   - rename "WebContinuation" to "FlowState", and accordingly 
> "WebContinuationManager" to "FlowStateManager".
> 
> 2/ In the sitemap language. These changes can be disruptive with 
> existing sitemaps, but we can provide (although we aren't in beta) a 
> compatibility mode :
>    - rename <map:call function=""> to <map:call flow=""> or <map:call

> controller="">
>    - rename <map:call continuation=""> to <map:call state="">

Compared with the last vote 
[http://archives.real-time.com/pipermail/cocoon-devel/2003-July/016879.h
tml] 
following items have changed and we need to vote on them again:


  [A] The "Cocoon Advanced Control Flow" provides a controller that is
      linked into the sitemap (as **child element** of <map:sitemap
.../>:
     
      <map:flow type="[yourEngine]">
          [configuration]             
      </map:flow>

      This reflects that the flow is not a *usual* sitemap resource but
      something else.
     

  [B] The controller is called by:

      <map:call flow="[yourFlow]">
        <map:parameter name="x" value="y"/>
      </map:call>


  [C] A state of the controller is called by:

	<map:call state="">
        <map:parameter name="x" value="y"/>
     </map:call>


  [D] All flow interpreters[3] are Avalon components and declared
      in the cocoon.xonf:
         
      <flow-engine default="[yourController]" logger="[yourLogger]">
        ... 
      </flow-engine>

  
  [E] Changes in the current Javascript implementation:
      - rename "Interpreter" to "FlowEngine",
      - rename "WebContinuation" to "FlowState", and accordingly 
        "WebContinuationManager" to "FlowStateManager".


Please cast your votes!

Cheers,
Reinhard

PS: Probably I will not be able to count the votes and summarize the
result as
I'll be on vacation :-)




Mime
View raw message