cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Howard <coc...@leverageweb.com>
Subject Re: Cocoon 2.1 showstopper?
Date Mon, 16 Jun 2003 11:20:50 GMT
At 02:20 AM 6/16/2003, you wrote:
>Hi,
>
>I think I found a showstopper for 2.1 :( :
>2.1 is not binary compatible to 2.0.x - if you compile a (sitemap)
>component using 2.0.x and put this into 2.1 it will in most cases
>fail to run. As a simple example, you can use the FileGenerator.class
>from 2.0.x.

...

>So, the question is: do we want to have this kind of compatibility
>or do the users have to recompile (which works of course as we are
>compatible on the source level)?

I think we'd have to poll the users list (and any large scale users
we know of that may not be on the list if we really want to be nice)
but if this is just a matter of recompiling, not recoding I don't
think that's too much to ask.

Geoff 


Mime
View raw message