cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Upayavira" ...@upaya.co.uk>
Subject Re: latest 2.1-dev CVS: java.lang.NoSuchMethodError:
Date Thu, 12 Jun 2003 09:17:10 GMT
On 12 Jun 2003 at 9:58, Stephan Michels wrote:

> 
> 
> On Wed, 11 Jun 2003, Berin Loritsch wrote:
> 
> > Rob Johnston wrote:
> > > Is this a bug that I should report?  I spoke to someone else who
> > > had the exact same problem with cocoon 2.1-dev under FreeBSD (over
> > > a month ago) & he said his solution was to "not ship with support
> > > for FreeBSD" -- which isn't a viable option for us (even though
> > > the jdks for FreeBSD are not "officially" supported by Sun).
> 
> Yes, this not a solution.
> 
> > > Does this look more like a cocoon problem or an excalibur problem?
> > >
> >
> > It looks like you have the wront Event JAR in your classpath.
> 
> I can reproduce this exception on Linux/PPC/blackdown-1.3 . Until now
> I don't find the time to solve this. So, you're not alone ;-)
> 
> Seems to be a problem with older JDKs. I the last time we got more
> than once problems with a NoSuchMethodError, because most of the
> people work with a 1.4 JDK, which isn't backward compatible in every
> case.

All I can add here is that, in Tomcat on Windows, Cocoon works with JDK 1.3 and 
1.4. However, when debugging in Intelli-J IDEA, it only works with 1.4. 1.3 gives this 
same NoSuchMethodError. I've just worked around it myself by switching to 1.4, but 
this is a luxury not everyone will have.

Upayavira


Mime
View raw message