cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@s-und-n.de>
Subject RE: Authentication Framework possible bug
Date Thu, 22 May 2003 06:22:36 GMT
Hi,

how does your sitemap look like? (The pipeline with the auth-protect
action).

Carsten

PS: Please send emails in plain text and not html.

-----Original Message-----
From: Stephen Burns [mailto:stephen.burns@tias.com.au]
Sent: Thursday, May 22, 2003 7:45 AM
To: cocoon-dev@xml.apache.org
Subject: Authentication Framework possible bug


Im having problems with the lastest build regarding the authentication
framework.

We have a set up like this:
                        <authentication-manager>
                                    <handlers>
                                                <handler
name="IntegratorHandler">
                                                                        <!--
                                                                        This
document is displayed when a unauthorized user

tries to access a protected document
                                                                        -->

<redirect-to uri="cocoon:/login"/>
                                                                        <!--
                                                                        A
Cocoon pipeline trying to authenticate a user
                                                                        -->

<authentication uri="cocoon:raw:/authConfig"/>


<applications>

<application name="boris" loadondemand="true">

<load uri="cocoon://controller/login-boris"/>

</application>
.(more applications here).

<application name="profile" loadondemand="true">

<load uri="cocoon://controller/login-profile"/>

</application>

<application name="product" loadondemand="true" />

<application name="splash" loadondemand="true" />

</applications>
                                                </handler>
                                    </handlers>
                        </authentication-manager>

When we try to access a protected resource belonging to the boris
application, the loadApplicationXML method of AuthenticationContext fails.
More specifically it appears to be the line
        final String applicationName =
RequestState.getState().getApplicationName();
of the method createParameters that fails because, Request.getState is null.

Any help appreciated,
Thanks
Stephen


Mime
View raw message