cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Howard" <coc...@leverageweb.com>
Subject [SOLVED] RE: javadocs not building?
Date Sat, 03 May 2003 16:33:28 GMT
Ok, this was interesting and I finally stumbled on a clue.  I
have no idea if this will occur to anyone else, but might as
well post back with what was happening just in case.

The short: I was still using JDK build 1.4.0-b92 (hey, it was
bleeding edge once...) and there must be some bug with its
javadoc processing, which caused it to interpret
org.apache.cocoon.components.language.programming.java
as a source java file instead of a directory containing
a package.  Upgrading to an actual release fixed it.

Live and learn,
Geoff

> -----Original Message-----
> From: Geoff Howard [mailto:cocoon@leverageweb.com]
> Sent: Thursday, April 17, 2003 9:13 PM
> To: cocoon-dev@xml.apache.org
> Subject: javadocs not building?
>
>
> Am I the only one not getting javadocs from the build?  I get:
>
> javadocs:
> Generating Javadoc
> Javadoc execution
> Loading source file
> org.apache.cocoon.components.language.programming.java...
> error: cannot read: org.apache.cocoon.components.language.programming.java
> Loading source files for package org.apache.cocoon...
> Loading source files for package org.apache.cocoon.acting...
> <snip/>
> Loading source files for package org.apache.cocoon.components.xslt...
> 1 error
>
> I've checked and of course
> src/java/org/apache/cocoon/components/language/programming/java
> is indeed there and I don't see anything wrong with it.  Before I start
> hunting
> all over the place, I thought it wise to check that I'm not the only one
> seeing this.
>
> Win2k, JDK1.4
>
> Geoff
>
>
>


Mime
View raw message