cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Burns" <stephen.bu...@tias.com.au>
Subject Authentication Framework possible bug
Date Thu, 22 May 2003 05:44:35 GMT
Im having problems with the lastest build regarding the authentication
framework.

 

We have a set up like this:

                        <authentication-manager>

                                    <handlers>

                                                <handler
name="IntegratorHandler">

 
<!--

 
This document is displayed when a unauthorized user

 
tries to access a protected document

 
-->

 
<redirect-to uri="cocoon:/login"/>

 
<!--

 
A Cocoon pipeline trying to authenticate a user

 
-->

 
<authentication uri="cocoon:raw:/authConfig"/>

 

 
<applications>

 
<application name="boris" loadondemand="true">

 
<load uri="cocoon://controller/login-boris"/>

 
</application>

...(more applications here)...

 
<application name="profile" loadondemand="true">

 
<load uri="cocoon://controller/login-profile"/>

 
</application>

 
<application name="product" loadondemand="true" />

 
<application name="splash" loadondemand="true" />

 
</applications>

                                                </handler>

                                    </handlers>

                        </authentication-manager>

 

When we try to access a protected resource belonging to the boris
application, the loadApplicationXML method of AuthenticationContext
fails.  More specifically it appears to be the line

        final String applicationName =
RequestState.getState().getApplicationName();

of the method createParameters that fails because, Request.getState is
null.

 

Any help appreciated,

Thanks

Stephen

 


Mime
View raw message