cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agsoftware.dnsalias.com>
Subject Re: input module stopped working
Date Sun, 18 May 2003 12:28:24 GMT
Try to comment the line. I dont know where you get the "iniva" stuf.

Antonio Gallardo

Jeremy Quinn dijo:
> Hi All
>
> I just updated to the latest CVS and an input module I had setup
> stopped working.
>
> Any ideas what might be wrong?
>
> This is the declaration in the 'input-modules' section of
> 'cocoon.xconf':
>
> <component-instance
> class="org.apache.cocoon.components.modules.input.XMLFileModule"
>   logger="core.modules.xml" name="iniva-conf">
>    <file src="cocoon://iniva/xconf"/>
> </component-instance>
> <component-instance
> class="org.apache.cocoon.components.modules.input.ChainMetaModule"
>   logger="core.modules.input" name="iniva">
>    <input-module name="request-param"/>
>    <input-module name="simplemap">
>      <prefix>/vars/</prefix>
>      <input-module name="iniva-conf"/>   <!-- this is line:218 of
> cocoon.xconf -->
>    </input-module>
> </component-instance>
>
> If I access http://localhost:8080/cocoon/iniva/xconf I get the correct
> content.
>
> In core.log I get this error:
>
> ERROR   (2003-05-18) 12:51.58:190   [core.modules.xml]
> (/cocoon/iniva/index) Thread-15/XMLFileModule: Error: missing 'file'
> child element at jndi:/localhost/cocoon/WEB-INF/cocoon.xconf:218:39
>
> Thanks for any help
>
> regards Jeremy




Mime
View raw message