cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Mazzocchi <stef...@apache.org>
Subject Re: [FYI] Stefano's Linotype
Date Thu, 24 Apr 2003 16:15:35 GMT
on 4/24/03 5:35 PM iasandcb@apache-korea.org wrote:

> I tried your Linotype and found that it needed cocoon-2.1. (I attempted to
> use cocoon-2.0 but Linotype said "invalid configuration schema", so I opened
> cocoon.xconf and read <cocoon version="2.1"> :-)

As I wrote, you need to copy the WEB-INF/lib after you build cocoon our
of CVS.

> I deployed linotype application to Tomcat 4.1.24 with JDK 1.4.1_02, and
> fixed sitemap.xmap to replace two elements with
> org.apache.cocoon.generation.JXTemplate to be compliant with the latest
> cocoon-2.1 CVS. 
> 
> I called http://localhost:8080/linotype/ with Mozilla 1.4 and the following
> response appeared.
> 
> Internal Server Error
> 
> Message: null
> 
> Description: No details available.
> 
> Sender: org.apache.cocoon.servlet.CocoonServlet
> 
> Source: Cocoon Servlet
> 
> Request URI
> 
> cause
> 
> java.lang.IllegalArgumentException: The output format must have a
> '{http://xml.apache.org/xslt}content-handler' property!
> 
> request-uri
> 
> /linotype/
> 
> Do I have to do something else more to run linotype? Thanks very much in
> advance.

no, this is the good old 'endorsed lib' problem.

Just place the latest xerces and xalan in your endorsed lib.

-- 
Stefano.



Mime
View raw message