cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <>
Subject Re: [Fwd: [heads-up] Updated upload system and fixed a bunch of security issues]
Date Fri, 04 Apr 2003 16:05:28 GMT
Stefano Mazzocchi wrote:

> Sylvain Wallez wrote:
>> What's the real contract behind "Object get(String)" ? The method 
>> name isn't very meaninful and the JavaDoc is confusing, as it is 
>> identical to the one for getAttribute(), although the implementation 
>> is obviously different.
>> Furthermore, is get() useful for something other than file upload ? 
>> If not, why don't we define "Object getMultipartPart(String)" and 
>> remove/deprecate this method ?
> MultipartHttpServletRequest is never accessed directly, so this 
> contract isn't really meaningful.
> The *real* contract is o.a.c.environment.Request which already contains
>  object get(name);
> and this should be changed to something more meaningful, but this 
> requires much more thinking also to think about mail processing.

I understand, but (again) what's the purpose of this get(), which is 
obviously not what is said by its Javadoc ?

>> We could even add this "InputPart" you're talking about to the 
>> enviromnent, inspired by o.a.c.c.request.multipart.FilePart.
> yes, but I didn't want to mess with the environment right before the 
> release. 

Ok. We also have to consider (just had this idea) that uploaded parts 
don't make sense only in the servlet environment : in a mailet 
environment, this could also be used for email attachments.

BTW, I remember someone (was it Nicola Ken ?) saying it was working on 
such a mailet environment. Any news ?


Sylvain Wallez                                  Anyware Technologies 
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }

View raw message