cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17623] - Incorrect caching behaviour
Date Tue, 08 Apr 2003 02:06:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17623>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17623

Incorrect caching behaviour





------- Additional Comments From alex@romayev.com  2003-04-08 02:06 -------
Carsten,

I've tried the test with the latest version and it still does not work.  I 
believe you should not have simplified it.  The key here is (the way it appears 
to me) the change in the request parameter, which does not get picked.

I've created two files:
en.xml:
<text>Hello world - English</text>
ru.xml:
<text>Hello world - Russian</text>

Follow the steps below:
1. Type http://localhost:8080/cocoon/a.resource?locale=en, the browser will 
display: "Hello world - English" -- correct
2. Type http://localhost:8080/cocoon/a.portlet?locale=en, the browser will 
display: "Hello world - English" -- correct
3. Type http://localhost:8080/cocoon/a.portlet?locale=ru, the browser will 
display: "Hello world - English" -- INCORRECT
4. Type http://localhost:8080/cocoon/a.resource?locale=ru, the browser will 
display: "Hello world - Russian" -- correct
5. Type http://localhost:8080/cocoon/a.portlet?locale=ru, the browser will 
display: "Hello world - English" -- STILL INCORRECT!

I hope this helps.

Mime
View raw message