cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Butler, Mark" <Mark_But...@hplb.hpl.hp.com>
Subject RE: Cocoon 2.0.4 & deli 0.9.1
Date Thu, 13 Mar 2003 11:16:42 GMT
Hi Jean-Pierre

Sorry about the delay, I was out the office yesterday.

> Hello all. 
> I write to this list to ask you an integration question regarding deli
> 0.9.1 and current (stable) cocoon 2.0.4.
> 
> We want to use last DELI version to implement rdf for multiple
> terminals. I've downloaded it from sourceforge, compiled, 
> then tried to
> use deli.jar in place of deli-0.5.0.jar. But it doesn't work! 
> It ends up
> with a java exception 

I wouldn't expect this to work - DELI in 2.0.4 was broken (this was my
fault) as the directory structure changed so it couldn't find the
deliConfig.xml file.

I'm working at the moment to fix this, and integrate the latest version of
DELI into C2 but due to the ongoing refactoring I still haven't been able to
check everything (particularly the samples) is in full working order.
However I want to stress I think the refactoring work is excellent, thanks
to everyone working on this, and problems with DELI are my responsibility.
Several people have expressed interest in C2+DELI over the last 3 weeks.
Unfortunately I've been back and forth to the US twice in that time, so it's
been hard to get time to do this, but I hope to get it done RSN :-)

However, if you want to get things to work now with 2.0.4 I suggest that:

1. You've got the DELI source also - right? The relevant lines in DELI are
235 to 285 in Workspace.java. As you can see, it should now print some extra
debug information to the console if it can't find the config file - are you
getting anything at the console? This will help you find the source of the
problem. You can set where DELI is trying to load the config file in
deli.xconf. I think in 2.0.4 it will be something like

<parameter name="deli-config-file"
value="resources/deli/config/deliConfig.xml"/>

but it should be

<parameter name="deli-config-file"
value="WEB-INF/deli/config/deliConfig.xml"/>

2. You need to update the config files. Specifically DELI 0.5 / 0.6.5 used
the concept of legacy profiles, and namespace information was set in the
deliConfig.xml. DELI 0.9 uses more advanced ideas such as local profiles and
a separate namespace information file. You can get the files you need from
src/blocks/deli/WEB-INF/deli from the 2.1 CVS tree (To save time I'll email
them to you, but not to the C2-dev list). 

> I thought it was related to DeliImpl.class in 
> cocoon-2.0.4.jar, so I've
> tried to use those DELI components from cocoon-cvs (which is shipped
> with deli 0.9.0), but a problem still arises, this time in an 
> Excalibur
> component. This is going to be a neverending problem I think :-)

I don't think you need to update DeliImpl.java - in fact as you've found
out, I think it will create problems. Some changes have been made to the
imports for DeliImpl.java due to changes in Avalon. Apart from that though,
the only difference is the Parser class at line 127 and 154 was renamed
DOMParser. I suggest you stick with the 2.0.4 version of DeliImpl, and just
update the config files?

No, it should be fixed soon. Feel free to email me directly for support. 

br,

Mark H. Butler, PhD
Research Scientist                HP Labs Bristol
mark-h_butler@hp.com
Internet: http://www-uk.hpl.hp.com/people/marbut/





Mime
View raw message