cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Oliver <>
Subject Re: Polishing the flow contracts
Date Mon, 31 Mar 2003 15:57:16 GMT
Stefano Mazzocchi wrote:

>>>>> Flow Object:
>>>>>  flow.import() -> imports another flowscript 

import is a JavaScript keyword. We can't use it as the name of a function

>>>> Hmmm... Should we allow cross-language (when/if we're going to have 
>>>> it)
>>>> flowscripts interaction? Because otherwise I'd prefer a name such as
>>>> "interpreter"....
>>> I don't get it. What's wrong with the name flow?
>> I think the same as Pier here, you merely don't include a flow, but
>> include or import another javascript file. Using flow here, I think,
>> leads the user to false assumption, that this is flow specific.
>> For instance using jruby or another great scripting language (jython,
>> ...), this would work somewhat different like Module::include in jruby
>> or import in jython.
> Ok, I agree with you people.
> I wonder, doesn't javascript have such a native facility for importing 
> external scripts? I would be surprised if it didn't.
It doesn't. It's up to the embedding how this is accomplished. Rhino and 
Spidermonkey (Mozilla engines) have "load()".


View raw message