cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Oliver <res1c...@verizon.net>
Subject Re: [GUMP] Build Failure - Cocoon
Date Thu, 27 Mar 2003 18:29:48 GMT
Sam Ruby wrote:
> Christopher Oliver wrote:
> 
>> Stefano Mazzocchi wrote:
>>
>>>>     [javac] 
>>>> /home/rubys/jakarta/cocoon-2.1/src/java/org/apache/cocoon/components/flow/javascript/JavaScriptInterpreter.java:194:

>>>> cannot resolve symbol
>>>>     [javac] symbol  : method setOptimizationLevel (int)
>>>>     [javac] location: class org.mozilla.javascript.tools.debugger.Main
>>>>     [javac]             db.setOptimizationLevel(OPTIMIZATION_LEVEL);
>>>>     [javac]               ^
>>>
>>>
>>> Chris,
>>>
>>> I think your latest rhino debugging modifications broke Gump. Can you 
>>> please help me taking care of this? TIA.
>>>
>>> Stefano.
>>
>>
>> Sure, I'd like to. But I don't understand how this error could be 
>> generated unless Gump is using the non-continuations-enabled version 
>> of  Rhino? Can you configure Gump to build against the the version 
>> from cocoondev.org? Or what's the best approach?
> 
> 
> Gump builds Rhino from cvs and then builds cocoon using that version of 
> Rhino.  So the question is: how does one build a "continuations enabled" 
> version of Rhino from cvs?
> 
>> Regards,
>>
>> Chris
> 
> 
> - Sam Ruby
> 

Here's how I do it:

export CVSROOT=:pserver:anoncvs@cvs.cocoondev.org:/var/cvs/rhino
cvs co rhino1_5Rpre
cd rhino1_5R4pre
ant jar
cp build/rhino1_5R4pre/js.jar <wherever>


Is that enough information?

Regards,

Chris




Mime
View raw message