cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Mazzocchi <stef...@apache.org>
Subject Re: [Patch] cocoon.bat issues
Date Sat, 15 Mar 2003 12:53:39 GMT
Jeff Ramsdale wrote:
> With recent updates of Cocoon 2.1-dev from CVS I haven't been able to get
> the embedded Jetty to start up (Windows ME, j2sdk1.4.0). Turning echo on I
> discovered 2 endless loops in cocoon.bat. Initially there were duplicate
> gotPort and  gotWebapp labels; I changed the duplicate names.
> 
> I then received an error of: "The program issued a command but the command
> length is incorrect." Checking out the file again I was confused by the
> following code to set EXEC:
> 
>   if not "%EXEC%" == "" goto gotExec
>   set EXEC=start "Cocoon" /D. /MAX
>   :gotExec

ah, right, the above works with 'cmd.exe' (NT/2k/XP) not with 
'command.com' (95/98/ME)

> I have no idea what this is supposed to do but it just didn't look right.

this means

  start -> start a window
  /D. -> with directory '.'
  /MAX -> maximize the window

but this only works on NT/2k/XP, I forgot to add a check for that.

> Forward slashes in a .bat file? 

Oh, yes. almost all DOS commands used forward slashes as command line 
parameters.

> So I deleted the code and references to
> %EXEC in doServlet, doServletAdmin, and doDebug and everything seemed to
> work fine. Any clues for me?
> 
> I've included my first Cocoon patch, generated with Eclipse. I didn't submit
> to Bugzilla--let me know if I should--but I wanted feedback on the EXEC
> issue before I went that far.

I just patched it but I won't be able to test it now that I don't have a 
win95/98/ME machine to test it on. So tell me if it worked.

Stefano.





Mime
View raw message