cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Oliver <res1c...@verizon.net>
Subject Re: Eclipse javac is screwed?
Date Tue, 11 Mar 2003 17:11:28 GMT
Hi Vadim,

The EclipseJavaCompiler is currently hardcoded with source=1.4 and 
target=1.4. This is because I didn't know how to configure those 
properties through the available Cocoon interfaces. There is nothing 
wrong with the Eclipse compiler itself, only with my code. Either we can 
hardcode it with source=1.3 target=1.3 in which case it will work under 
jdk1.3.1 or we need to make it configurable.

Regards,

Chris

Vadim Gritsenko wrote:
> Got this:
> 
> 09:36:38.789 WARN!! Error for /samples/xscript/simple
> java.lang.UnsupportedClassVersionError: 
> org/apache/cocoon/www/samples/docs/samples/xscript/simple_xsp 
> (Unsupported major.minor version 48.0)
>        at java.lang.ClassLoader.defineClass0(Native Method)
> 
> 
> Seems like eclipse compiler is screwed badly under jdk 1.3.1... Can it 
> be configured to work properly?
> 
> PS Pizza works just fune
> 
> Vadim
> 
> 
> 



Mime
View raw message