cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Wallez <sylvain.wal...@anyware-tech.com>
Subject Re: Redirects to cocoon: URIs broken
Date Mon, 10 Mar 2003 10:42:13 GMT
Ugo Cei wrote:

> If you apply the attached patch (which just adds a simple 
> <map:redirect-to>) to the current CVS and try to load the default 
> Cocoon home page for the webapp, you'll get a nice NPE at 
> org.apache.cocoon.environment.AbstractEnvironment.resolveURI(AbstractEnvironment.java:467).

>
>
> This is the same problem that causes bug #17673 [1] and it affects all 
> redirects to URIs of the form "cocoon:/*". It is apparently due to 
> AbstracEnvironment.startingProcessing not being called and 
> consequently the sourceResolver member not being initialized.
>
> Right now, I'm printing out stacktraces and looking at the call graph 
> for the involved methods, but I'm not very familiar with the internals 
> of sitemap processing and thus I'm going very slowly.
>
> Excuse me if I'm insisting on this, but this bug is breaking the whole 
> flow plus a lot more things, I think.


Yep. It broke the I18N samples where there was <map:redirect-to 
uri="cocoon:/simple.xml"/>

I changed it to <map:redirect-to uri="simple.xml"/> which solves the 
effect on this particular sample, but not the cause...

Sylvain

-- 
Sylvain Wallez                                  Anyware Technologies
http://www.apache.org/~sylvain           http://www.anyware-tech.com
{ XML, Java, Cocoon, OpenSource }*{ Training, Consulting, Projects }



Mime
View raw message