cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Crafter <craft...@fztig938.bank.dresdner.net>
Subject Eclipse compiler targetting JDK 1.4
Date Tue, 11 Mar 2003 14:48:29 GMT
Hi Troops,

	Hope all is well.
	
	Some people on the users list discovered that the Eclipse Java 
	compiler we're using for XSP is set to target a 1.4 runtime 
	environment, which causes problems when running your application
	under 1.3.
	
	Any thoughts ? should we make the EclipseJavaCompiler class 
	target 1.3 only, or make the class format target configurable, or
	some other option ?
	
	Cheers,
	
	Marcus

----- Forwarded message from Alexander Enns <Alexander.Enns@bdal.de> -----

Envelope-to: crafterm@fztig938.bank.dresdner.net
Delivery-date: Tue, 11 Mar 2003 15:02:12 +0100
Posted-Date: Tue, 11 Mar 2003 15:02:11 +0100 (MET)
Mailing-List: contact cocoon-users-help@xml.apache.org; run by ezmlm
Reply-To: cocoon-users@xml.apache.org
From: "Alexander Enns" <Alexander.Enns@bdal.de>
To: <cocoon-users@xml.apache.org>
Subject: Re: Axis as Cocoon component?

Hi Markus,

the problem was realy the compiler settings.
I have changed the compiler setting to Javac. Now all working properly.

At last I can begin to play with SoapServer. :-)

Thanks for Your help,

Alexander

>>> Marcus Crafter <crafterm@fztig938.bank.dresdner.net> Tuesday, 11. March
2003 14:10:05 >>>
On Tue, Mar 11, 2003 at 01:38:07PM +0100, Stephan Michels wrote:
> 
> 
> On Tue, 11 Mar 2003, Marcus Crafter wrote:
> 
> > Hi Alexander,
> >
> > On Tue, Mar 11, 2003 at 11:54:46AM +0100, Alexander Enns wrote:
> > >
> > > Java 1.3.1
> > > ...
> > >
> > > java.lang.UnsupportedClassVersionError: org/apache/cocoon/www/test_xsp
> > >  (Unsupported major.minor version 48.0)
> >
> > 	I suspect the XSP files have been compiled using jdk 1.4.x and
> > 	you're attempting to run them using jdk 1.3.1. Could that be the
> > 	case ?
> >
> > 	I'd clean out your work directory (ie. remove the xsp class files)
> > 	and see then if the problem persists.
> 
> I got the same exception, but I doesn't use a 1.4 jdk. Can it be that
> we currently using a XSP compiler, which targets at 1.4?

	Could be. The default XSP compiler was changed recently from javac
	to Eclipse.
	
	There's no chance that the XSP pages were compiled with jdk 1.4
	sometime in the past and are left over in your work directory ?
	(it's happened to me :) )

	If not, can you perform your same test using the Javac compiler
	(the settings can be modified in your cocoon.xconf), and report
	back your results ?
	
	Thanks! Cheers,
	
	Marcus

-- 
        .....
     ,,$$$$$$$$$,      Marcus Crafter
    ;$'      '$$$$:    Computer Systems Engineer
    $:         $$$$:   ManageSoft GmbH
     $       o_)$$$:   82-84 Mainzer Landstrasse
     ;$,    _/\ &&:'   60327 Frankfurt Germany
       '     /( &&&
           \_&&&&'
          &&&&.
    &&&&&&&:


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-users-unsubscribe@xml.apache.org
For additional commands, e-mail: cocoon-users-help@xml.apache.org


----- End forwarded message -----

Mime
View raw message