cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17594] New: - WebSphere redirect bug
Date Mon, 03 Mar 2003 13:35:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17594>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17594

WebSphere redirect bug

           Summary: WebSphere redirect bug
           Product: Cocoon 2
           Version: 2.0.4
          Platform: Other
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: core
        AssignedTo: cocoon-dev@xml.apache.org
        ReportedBy: A.Marchanka@admsysnet.com


Hi,
I am work with Cocoon 2.0.4 and WebSphere 4.0.4
When I am using redirect, I have 
unpredictable behavior
i.e.
<map:redirect> does not work properly 
(WebSphere bug 
response.encodeRedirectURL() - always return full path start with http://)
I am using patch
--- 
HttpEnvironment.java    2003-03-03 14:52:26.000000000 +0200
+++ HttpEnvironment.java    2003-03-
03 14:57:24.000000000 +0200
@@ -190,9 +190,6 @@
         if (!newURL.startsWith("/") && 
newURL.indexOf(':') == -1 && redirect.indexOf(':') != -1) {
             getLogger().debug("Redirect: 
WebSpehere Bug Detected!");
             String base = NetUtils.getPath(request.getRequestURI());
-            
if (base.startsWith("/")) {
-                base = base.substring(1);
-            }
             redirect = 
response.encodeRedirectURL(base + '/' + newURL);
         }

and all work fine. But may be it's 
behavior only WebSphere 4.0.4 on Win 2k
It's bug present in 2.0.3 too.

Mime
View raw message