cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <>
Subject Re: exclusion of certain blocks from build is busted
Date Sun, 16 Mar 2003 03:33:25 GMT
Bernhard Huber wrote:
> David Crossley wrote:
> >Today one of the blocks is broken. I tried to get around
> >it as usual by un-commenting the line in
> >to no avail.
> i made a CVS update, and had no problem running "build webapp",
> i even tried setting in all
> entries from
> #exclude.block.XXX=true to
> exclude.block.XXX=true
> and no block compilation was performed.
> which block is broken?

Thanks to Bernhard and Stefano for following up.

However, i still get the same problem with today's CVS.
The Lucene block is broken and i cannot get around it.

cvs update cocoon-2.1 ... no issues
./ clean
./ webapp
.../cocoon-2.1/src/blocks/lucene/java/org/apache/cocoon/transformation/ cannot resolve symbol
symbol  : class NOPCacheValidity
location: package caching
import org.apache.cocoon.caching.NOPCacheValidity;
.../cocoon-2.1/src/blocks/lucene/java/org/apache/cocoon/transformation/ cannot resolve symbol
symbol  : variable NOPCacheValidity
location: class org.apache.cocoon.transformation.LuceneIndexTransformer
        return NOPCacheValidity.CACHE_VALIDITY;
2 errors

 un-comment the lucene block to exclude it
./ clean
./ webapp
... same problem.

So i am confused.


View raw message