cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <>
Subject RE: Removing deprecated dependencies (XSPUtil, XScriptObject)
Date Thu, 27 Feb 2003 14:37:04 GMT

Vadim Gritsenko wrote:
> Carsten Ziegeler wrote:
> >Hi,
> >
> >I'm currently trying to remove all dependencies from the core
> >to the deprecated "block". I nearly removed all dependencies
> >that could be removed except for the following two:
> >
> >XScriptObject implements the old deprecated Source interface.
> >Can this be changed without breaking something to the
> >new Avalon Source interface? (If so, I can do this).
> >
> Yes, please, go ahead. Just note that xscript.xsl depends on it, so it 
> has to be changed accordingly.
Can someone with more knowledge of XSP please update this? I can
if required update the XScriptObject, but not the stylesheets.

> In distant future I would like this to be merged with data object behind 
> session-fw, to have unified store of XML data...
> >XSPUtil - this XSP helper class offers some static methods
> >that use the old Parser and URLFactory interface. Can they
> >be removed/changed without breaking something in the xsp
> >stylesheets?
> >
> Logicsheets has to be updated too if they use these methods.
Ok, again, can someone with XSP knowledge update this?


View raw message