cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Unico Hommes" <Un...@hippo.nl>
Subject RE: Problems reloading subsitemap
Date Tue, 11 Feb 2003 15:28:09 GMT

Yep, that's it. I am using a recent CVS avalon-framework and ECM. I dropped them in the cocoon
webapp and got the same error. Unfortunately my system uses those recent features. Hmm, I'm
gonna have to get this working. Guess I'll be digging.

Unico Hommes wrote:
> 
> Sylvain Wallez wrote:
> > 
> > Unico Hommes wrote:
> > 
> > >Hi,
> > >
> > >I am running into a problem with reloading of subsitemaps. 
> > After initial startup everything runs fine but once I change 
> > a subsitemap treeprocessor can not find the correct 
> > components anymore. In fact it seems that the component 
> > locator in the CM is no longer valid. I am seeing the 
> > following warning in my logs. 
> > >
> > >WARN    Thread-6   12:13:35:177 [sitemap] (): 
> > ComponentLocator exception from parent CM during lookup.
> > >java.lang.IllegalStateException: You cannot lookup 
> > components on a disposed ComponentLocator
> > >	at 
> > org.apache.avalon.excalibur.component.ExcaliburComponentManage
> > r.lookup(ExcaliburComponentManager.java:156)
> > >	at 
> > org.apache.cocoon.components.CocoonComponentManager.lookup(Coc
> > oonComponentManager.java:242)
> > >	at 
> > org.apache.avalon.excalibur.component.ExcaliburComponentManage
> > r.lookup(ExcaliburComponentManager.java:181)
> > >	at 
> > org.apache.cocoon.components.CocoonComponentManager.lookup(Coc
> > oonComponentManager.java:242)
> > >	at 
> > org.apache.cocoon.components.treeprocessor.DefaultTreeBuilder.
> > getTypeForStatement(DefaultTreeBuilder.java:531)
> > >
> > 
> > <snip/>
> > 
> > Well, this should be my job to fix this, but I'm currently 
> > out of time :-(
> > 
> > Has somebody changed something recently in the 
> TreeProcessor, or have 
> > time to dig further ?
> > 
> 
> No panic though, when I build the webapp from current CVS and 
> deploy cocoon.war there is no problem. It must be something 
> in the way I setup everything in my specific system. Perhaps 
> some clashing avalon classes (the framework I use is more 
> recent), or something in my environment context.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message