cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Upayavira" <upayav...@fwbo.org>
Subject Re: cli in cocoon.bat
Date Fri, 28 Feb 2003 08:45:41 GMT
> > 2) There are %2...%9, which gives you eight options. If you need to
> > specify a context dir, a config file, a working directory and a
> > destination directory, you've used them all up and haven't specified
> > any targets. Switching to %* almost sorted it (I know that this is
> > NT only), except that it passes 'cli' into the Main class. The SHIFT
> > command didn't seem to do anything, when it should have helped. You
> > just gotta love DOS. 
> should be fixed. try it out.

I've modified my Main.java to tell me what options it's getting:

Option[Option  , [cli] ]
Option[Option c, [build/webapp] ]
Option[Option C, [build/webapp/WEB-INF/cocoon.xconf] ]
Option[Option d, [/desktop/site] ]
Option[Option w, [/desktop/site] ]
Option[Option  , [/] ]
Target size:2
Target: cli
Target:

So for some reason, the shift isn't working for me. I presume it worked for you?

Also, it complains that it can't find javax/servlet/http/HttpSessionBindingListener. 
Adding .\server\lib\javax.servlet.jar to the classpath in the bat file worked, but 
that's a hack that should be done using your loader, I presume.

Upayavira


Mime
View raw message