cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klaus Bertram <k.bert...@kbsm.de>
Subject [PROBLEM] caching after map:aggregate
Date Thu, 20 Feb 2003 16:46:56 GMT
Hi all,

it seems that there is a caching problem after the map:aggregate module
in the followed transformer
at version 2.0.4 and 2.0.5 it works well but not in 2.1 dev

here a sample:
<map:match pattern="*.html">
   <map:aggregate element="site">
     <map:part src="cocoon:/book-{1}.xml"/>
     <map:part src="cocoon:/body-{1}.xml" label="content"/>
   </map:aggregate>
   <map:transform src="stylesheets/site2xhtml.xsl"/>
   <map:serialize/>
</map:match>

<map:match pattern="body-*.xml">
   <map:generate src="spezification/docs/test.xml"/>
   <map:transform src="stylesheets/site2xhtml.xsl">
     <map:parameter name="use-request-parameters" value="true"/>
    </map:transform>
   <map:serialize type="xml"/>
</map:match>

If index.html is called at the first time it works ok.
If it call's the next times with index.html?id=22 or index.html?id=aass
the first cached side after the aggregation are responded.
Not the new one of generation :(

one solution I found is:
   Set the transformer also to
     <map:parameter name="use-request-parameters" value="true"/>
   and the cache works correct

I think the caching of a transformer result after an aggregation must 
every time based on the request parameter.

Klaus



---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message