cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16825] New: - XMLForm Error when Repeat is first element
Date Wed, 05 Feb 2003 23:49:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16825>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16825

XMLForm Error when Repeat is first element

           Summary: XMLForm Error when Repeat is first element
           Product: Cocoon 2
           Version: 2.0
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: general components
        AssignedTo: cocoon-dev@xml.apache.org
        ReportedBy: mark@golden-orb.com


When you define a repeat as the first element of the xmlform it dosn't unroll 
correctly. I have found the reason but im not sure of the fix.

Inside XMLFormTransformer.java
unrollRepeatTag(Doc...)

there is the line
if(value_!=null)
{
   //stream back the recorder repeat content..
..
..
}

As far as i can tell "value_" gets set when a value is extracted from the model 
so it can be output. If a repeat tag is first then "value_" = null because no 
values have been extracted from the model yet. 
I have commented out the if statement with no side effects so far but i dont 
know all the code well enough (im sure it was put there for a reason :)

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message