cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <giac...@apache.org>
Subject Re: I18n Samples working?
Date Fri, 10 Jan 2003 19:04:31 GMT

I'd like to share this experience with you all.

I was gone crazy about this. All samples seemed to work except the i18n
ones. The page did not come with the usual flags but the text was lined up
all together with a bigger font as normal.

I've reinstalled almost everything you could think of: A new virgin cocoon
CVS checkout, new Tomcats, also new JDKs. But stll the same i18n page.

After I've build the war file on some different machines and
transfered to my computer, they all appeared correctly. Only the ones
build on machine must have been different.

After along try and searching I've found a .ant.properties file in my home
directory which contained the line:

    build.compiler=jikes

Well, after removing that line my build come up correct again.

I had a similar issue last year at Wyona when i helped them to speed up
their CMS onto Cocoon. The sample XSP pages we have in our webapp all have
a link to a beautified XSP source code page. On my build they where there
as expected. On the build of the Wyna guys the only had the text of the
link but no link. Well, the culprit there was, all others where using the
IBM JDK. After they switched to the Sun JDK the links reappeard.

This is indeed something that makes you loose confidence in those tool (of
course even the Sun JDK could have bugs, sure).

So the essence of these stories is:

    What do you order at 9am after a 10 hour debugging session of
    an XSP page that dosn't work as expected but you assured over a
    dozens times that it should?

            Pizza

Cheers

Giacomo


On Fri, 10 Jan 2003, Giacomo Pati wrote:

> On Thu, 9 Jan 2003, Bernhard Huber wrote:
>
> > hi,
> > havent' done any update now, my CVS is from yesterday evening.
> > flag imags are okay for me.
>
> I have the problem since today (oh, no, yesterday).
>
> >
> > crawled the commit changes, as a hint
> > maybe
> > sylvain     2003/01/09 10:20:19
> >
> >    Modified:    .        changes.xml
> >                 src/java/org/apache/cocoon/components/treeprocessor/sitemap
> >                          ReadNode.java ReadNodeBuilder.java
> >                          SerializeNode.java SerializeNodeBuilder.java
> >
> > src/java/org/apache/cocoon/components/treeprocessor/variables
> >                          PreparedVariableResolver.java VariableResolver.java
> >                 src/webapp/WEB-INF cocoon.xconf
> >    Log:
> >    Added sitemap variable expansion to "mime-type" in <map:read> and
> > <map:serialize>
> >
> > that causes troubles?
> >
> > does any images work?
>
> Everything else seems to work fine.
>
> Giacomo
>
> >
> > bernhard
> >
> > Giacomo Pati wrote:
> > > I'm driving mad, it had worked this morning, but now. Can someone confirm
> > > that the i18n sample in the current HEAD 2.1 is still working correctly?
> > >
> > > I don't have any flags but more or less unstyled text.
> > >
> > > TIA
> > >
> > > Giacomo
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> > > For additional commands, email: cocoon-dev-help@xml.apache.org
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> > For additional commands, email: cocoon-dev-help@xml.apache.org
> >
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message